using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(E|e|Ep|ep|episode|Episode) ?0*(?<sequencenumber>\d+)\D";
string input = @"[Erai-raws] One Piece - 004 [1080p]
[Erai-raws] One Piece - 006 [1080p]
[Erai-raws] One Piece - 009 [1080p]
[Erai-raws] One Piece - 037 [1080p]
[Erai-raws] One Piece - 082v2 [1080p]
[Erai-raws] One Piece - 0983 [1080p][Multiple Subtitle][1E6E13DB]
[Erai-raws] One Piece - 0988 [1080p][Multiple Subtitle][4311FFE4]
[Erai-raws] One Piece - 0993 [1080p][Multiple Subtitle][7E9CB1A1]
[Erai-raws] One Piece - 0996 [1080p][Multiple Subtitle][3AE37DDB]
[Erai-raws] One Piece - 1020 [1080p][Multiple Subtitle][E9F69D2D]
[Erai-raws] One Piece - 1064 [1080p][3D04E09D]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}