import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(E|e|Ep|ep|episode|Episode) ?0*(?<sequencenumber>\\d+)\\D";
final String string = "[Erai-raws] One Piece - 004 [1080p]\n"
+ "[Erai-raws] One Piece - 006 [1080p]\n"
+ "[Erai-raws] One Piece - 009 [1080p]\n"
+ "[Erai-raws] One Piece - 037 [1080p]\n"
+ "[Erai-raws] One Piece - 082v2 [1080p]\n"
+ "[Erai-raws] One Piece - 0983 [1080p][Multiple Subtitle][1E6E13DB]\n"
+ "[Erai-raws] One Piece - 0988 [1080p][Multiple Subtitle][4311FFE4]\n"
+ "[Erai-raws] One Piece - 0993 [1080p][Multiple Subtitle][7E9CB1A1]\n"
+ "[Erai-raws] One Piece - 0996 [1080p][Multiple Subtitle][3AE37DDB]\n"
+ "[Erai-raws] One Piece - 1020 [1080p][Multiple Subtitle][E9F69D2D]\n"
+ "[Erai-raws] One Piece - 1064 [1080p][3D04E09D]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}