$re = '/(E|e|Ep|ep|episode|Episode) ?0*(?<sequencenumber>\d+)\D/m';
$str = '[Erai-raws] One Piece - 004 [1080p]
[Erai-raws] One Piece - 006 [1080p]
[Erai-raws] One Piece - 009 [1080p]
[Erai-raws] One Piece - 037 [1080p]
[Erai-raws] One Piece - 082v2 [1080p]
[Erai-raws] One Piece - 0983 [1080p][Multiple Subtitle][1E6E13DB]
[Erai-raws] One Piece - 0988 [1080p][Multiple Subtitle][4311FFE4]
[Erai-raws] One Piece - 0993 [1080p][Multiple Subtitle][7E9CB1A1]
[Erai-raws] One Piece - 0996 [1080p][Multiple Subtitle][3AE37DDB]
[Erai-raws] One Piece - 1020 [1080p][Multiple Subtitle][E9F69D2D]
[Erai-raws] One Piece - 1064 [1080p][3D04E09D]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);