use strict;
my $str = '[Erai-raws] One Piece - 004 [1080p]
[Erai-raws] One Piece - 006 [1080p]
[Erai-raws] One Piece - 009 [1080p]
[Erai-raws] One Piece - 037 [1080p]
[Erai-raws] One Piece - 082v2 [1080p]
[Erai-raws] One Piece - 0983 [1080p][Multiple Subtitle][1E6E13DB]
[Erai-raws] One Piece - 0988 [1080p][Multiple Subtitle][4311FFE4]
[Erai-raws] One Piece - 0993 [1080p][Multiple Subtitle][7E9CB1A1]
[Erai-raws] One Piece - 0996 [1080p][Multiple Subtitle][3AE37DDB]
[Erai-raws] One Piece - 1020 [1080p][Multiple Subtitle][E9F69D2D]
[Erai-raws] One Piece - 1064 [1080p][3D04E09D]';
my $regex = qr/(E|e|Ep|ep|episode|Episode) ?0*(?<sequencenumber>\d+)\D/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}