using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*a=pattern:.*(?:\n(?!\s*a=).*)*";
string input = @"a=<random text>
a=pattern:<random text (may be fixed length)>
a=<random text>
a=<random text>
a=pattern:<random text (may be fixed length)>
this is a test
a=<random text>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}