import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*a=pattern:.*(?:\\n(?!\\s*a=).*)*";
final String string = "a=<random text>\n"
+ " a=pattern:<random text (may be fixed length)>\n"
+ " a=<random text>\n\n"
+ "a=<random text>\n"
+ " a=pattern:<random text (may be fixed length)>\n"
+ "this is a test\n"
+ " a=<random text>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}