$re = '/^\s*a=pattern:.*(?:\n(?!\s*a=).*)*/m';
$str = 'a=<random text>
a=pattern:<random text (may be fixed length)>
a=<random text>
a=<random text>
a=pattern:<random text (may be fixed length)>
this is a test
a=<random text>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);