re = /^\s*a=pattern:.*(?:\n(?!\s*a=).*)*/m
str = 'a=<random text>
a=pattern:<random text (may be fixed length)>
a=<random text>
a=<random text>
a=pattern:<random text (may be fixed length)>
this is a test
a=<random text>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end