#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<= ) | +$|(?<=\n)\n"
Local $sString = "test test " & @CRLF & _
"test " & @CRLF & _
"" & @CRLF & _
"test test " & @CRLF & _
"test "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)