re = /(?<= ) | +$|(?<=\n)\n/m
str = 'test test
test
test test
test '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result