$re = '/(?<= ) | +$|(?<=\n)\n/m';
$str = 'test test
test
test test
test ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;