use strict;
my $str = 'test test
test
test test
test ';
my $regex = qr/(?<= ) | +$|(?<=\n)\n/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";