package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9_-]{3,16}$`)
var str = `hi
hi!
hie
helloWorld
hello@world
hello_world
hello!world
hello-world`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}