re = /^[a-z0-9_-]{3,16}$/m
str = 'hi
hi!
hie
helloWorld
hello@world
hello_world
hello!world
hello-world'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end