import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9_-]{3,16}$";
final String string = "hi\n"
+ "hi!\n"
+ "hie\n"
+ "helloWorld\n"
+ "hello@world\n"
+ "hello_world\n"
+ "hello!world\n"
+ "hello-world";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}