$re = '/^[a-z0-9_-]{3,16}$/m';
$str = 'hi
hi!
hie
helloWorld
hello@world
hello_world
hello!world
hello-world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);