using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-]?[0-9]+[,.]?[0-9]*([\/][0-9]+[,.]?[0-9]*)*";
string input = @"123.4
123
21abc
3/4
23.4/21
-3
-4,55/2345.24
4.33/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}