re = /[-]?[0-9]+[,.]?[0-9]*([\/][0-9]+[,.]?[0-9]*)*/m
str = '123.4
123
21abc
3/4
23.4/21
-3
-4,55/2345.24
4.33/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end