// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[-]?[0-9]+[,.]?[0-9]*([\/][0-9]+[,.]?[0-9]*)*").unwrap();
let string = "123.4
123
21abc
3/4
23.4/21
-3
-4,55/2345.24
4.33/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}