package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-]?[0-9]+[,.]?[0-9]*([\/][0-9]+[,.]?[0-9]*)*`)
var str = `123.4
123
21abc
3/4
23.4/21
-3
-4,55/2345.24
4.33/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}