#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([NY|80]{2}[0-9]{5,6})_([a-zA-Z_]*)[^0-9]*_SFTP_([0-9]{4})([0-9]{2})([0-9]{2})"
Local $sString = "8008248_ProgramFact_SFTP_201902110400.csv" & @CRLF & _
"8008248_ProgramFact_SFTP_201902180400.csv" & @CRLF & _
"8008248_ProgramFact_SFTP_201902250400.csv" & @CRLF & _
"8008248_ProgramFact_SFTP_201903040400.csv" & @CRLF & _
"8008248_ProgramFact_SFTP_201903110400.csv" & @CRLF & _
"8008248_ProgramFact_SFTP_201903180400.csv" & @CRLF & _
"8008248_SchoolEnroll_SFTP_201902110400.csv" & @CRLF & _
"8008248_SchoolEnroll_SFTP_201902180400.csv" & @CRLF & _
"8008248_SchoolEnroll_SFTP_201902250400.csv" & @CRLF & _
"8008248_SchoolEnroll_SFTP_201903040400.csv" & @CRLF & _
"8008248_SchoolEnroll_SFTP_201903110400.csv" & @CRLF & _
"8008248_SchoolEnroll_SFTP_201903180400.csv" & @CRLF & _
"8008248_StudentLite_SFTP_201902110400.csv" & @CRLF & _
"8008248_StudentLite_SFTP_201902180400.csv" & @CRLF & _
"8008248_StudentLite_SFTP_201902250400.csv" & @CRLF & _
"8008248_StudentLite_SFTP_201903040400.csv" & @CRLF & _
"8008248_StudentLite_SFTP_201903110400.csv" & @CRLF & _
"8008248_StudentLite_SFTP_201903180400.csv" & @CRLF & _
"8008260_AttendanceCodes_SFTP_201903180401.csv" & @CRLF & _
"8008260_Courses_SFTP_201903140401.csv" & @CRLF & _
"8008260_Courses_SFTP_201903150401.csv" & @CRLF & _
"8008260_Courses_SFTP_201903160401.csv" & @CRLF & _
"8008260_Courses_SFTP_201903170401.csv" & @CRLF & _
"8008260_Day_Calendar_SFTP_201903180401.csv" & @CRLF & _
"8008260_LocationMarkingPeriod_SFTP_201903140406.csv" & @CRLF & _
"8008260_SchoolEnroll_SFTP_201903180400.csv" & @CRLF & _
"8008260_StudentLite_SFTP_201903180400.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")