# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([NY|80]{2}[0-9]{5,6})_([a-zA-Z_]*)[^0-9]*_SFTP_([0-9]{4})([0-9]{2})([0-9]{2})"
test_str = ("8008248_ProgramFact_SFTP_201902110400.csv\n"
"8008248_ProgramFact_SFTP_201902180400.csv\n"
"8008248_ProgramFact_SFTP_201902250400.csv\n"
"8008248_ProgramFact_SFTP_201903040400.csv\n"
"8008248_ProgramFact_SFTP_201903110400.csv\n"
"8008248_ProgramFact_SFTP_201903180400.csv\n"
"8008248_SchoolEnroll_SFTP_201902110400.csv\n"
"8008248_SchoolEnroll_SFTP_201902180400.csv\n"
"8008248_SchoolEnroll_SFTP_201902250400.csv\n"
"8008248_SchoolEnroll_SFTP_201903040400.csv\n"
"8008248_SchoolEnroll_SFTP_201903110400.csv\n"
"8008248_SchoolEnroll_SFTP_201903180400.csv\n"
"8008248_StudentLite_SFTP_201902110400.csv\n"
"8008248_StudentLite_SFTP_201902180400.csv\n"
"8008248_StudentLite_SFTP_201902250400.csv\n"
"8008248_StudentLite_SFTP_201903040400.csv\n"
"8008248_StudentLite_SFTP_201903110400.csv\n"
"8008248_StudentLite_SFTP_201903180400.csv\n"
"8008260_AttendanceCodes_SFTP_201903180401.csv\n"
"8008260_Courses_SFTP_201903140401.csv\n"
"8008260_Courses_SFTP_201903150401.csv\n"
"8008260_Courses_SFTP_201903160401.csv\n"
"8008260_Courses_SFTP_201903170401.csv\n"
"8008260_Day_Calendar_SFTP_201903180401.csv\n"
"8008260_LocationMarkingPeriod_SFTP_201903140406.csv\n"
"8008260_SchoolEnroll_SFTP_201903180400.csv\n"
"8008260_StudentLite_SFTP_201903180400.csv")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.