const regex = /([NY|80]{2}[0-9]{5,6})_([a-zA-Z_]*)[^0-9]*_SFTP_([0-9]{4})([0-9]{2})([0-9]{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([NY|80]{2}[0-9]{5,6})_([a-zA-Z_]*)[^0-9]*_SFTP_([0-9]{4})([0-9]{2})([0-9]{2})', 'gm')
const str = `8008248_ProgramFact_SFTP_201902110400.csv
8008248_ProgramFact_SFTP_201902180400.csv
8008248_ProgramFact_SFTP_201902250400.csv
8008248_ProgramFact_SFTP_201903040400.csv
8008248_ProgramFact_SFTP_201903110400.csv
8008248_ProgramFact_SFTP_201903180400.csv
8008248_SchoolEnroll_SFTP_201902110400.csv
8008248_SchoolEnroll_SFTP_201902180400.csv
8008248_SchoolEnroll_SFTP_201902250400.csv
8008248_SchoolEnroll_SFTP_201903040400.csv
8008248_SchoolEnroll_SFTP_201903110400.csv
8008248_SchoolEnroll_SFTP_201903180400.csv
8008248_StudentLite_SFTP_201902110400.csv
8008248_StudentLite_SFTP_201902180400.csv
8008248_StudentLite_SFTP_201902250400.csv
8008248_StudentLite_SFTP_201903040400.csv
8008248_StudentLite_SFTP_201903110400.csv
8008248_StudentLite_SFTP_201903180400.csv
8008260_AttendanceCodes_SFTP_201903180401.csv
8008260_Courses_SFTP_201903140401.csv
8008260_Courses_SFTP_201903150401.csv
8008260_Courses_SFTP_201903160401.csv
8008260_Courses_SFTP_201903170401.csv
8008260_Day_Calendar_SFTP_201903180401.csv
8008260_LocationMarkingPeriod_SFTP_201903140406.csv
8008260_SchoolEnroll_SFTP_201903180400.csv
8008260_StudentLite_SFTP_201903180400.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}