using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([NY|80]{2}[0-9]{5,6})_([a-zA-Z_]*)[^0-9]*_SFTP_([0-9]{4})([0-9]{2})([0-9]{2})";
string input = @"8008248_ProgramFact_SFTP_201902110400.csv
8008248_ProgramFact_SFTP_201902180400.csv
8008248_ProgramFact_SFTP_201902250400.csv
8008248_ProgramFact_SFTP_201903040400.csv
8008248_ProgramFact_SFTP_201903110400.csv
8008248_ProgramFact_SFTP_201903180400.csv
8008248_SchoolEnroll_SFTP_201902110400.csv
8008248_SchoolEnroll_SFTP_201902180400.csv
8008248_SchoolEnroll_SFTP_201902250400.csv
8008248_SchoolEnroll_SFTP_201903040400.csv
8008248_SchoolEnroll_SFTP_201903110400.csv
8008248_SchoolEnroll_SFTP_201903180400.csv
8008248_StudentLite_SFTP_201902110400.csv
8008248_StudentLite_SFTP_201902180400.csv
8008248_StudentLite_SFTP_201902250400.csv
8008248_StudentLite_SFTP_201903040400.csv
8008248_StudentLite_SFTP_201903110400.csv
8008248_StudentLite_SFTP_201903180400.csv
8008260_AttendanceCodes_SFTP_201903180401.csv
8008260_Courses_SFTP_201903140401.csv
8008260_Courses_SFTP_201903150401.csv
8008260_Courses_SFTP_201903160401.csv
8008260_Courses_SFTP_201903170401.csv
8008260_Day_Calendar_SFTP_201903180401.csv
8008260_LocationMarkingPeriod_SFTP_201903140406.csv
8008260_SchoolEnroll_SFTP_201903180400.csv
8008260_StudentLite_SFTP_201903180400.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}