using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^:])(/{2,})";
string substitution = @"$1/";
string input = @"http://static.test/aboroni/media//polo-shirts//
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}