package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(#\w+)|\d+`)
var str = `#foo1,bar2:#baz3 4`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}