$re = '/(#\w+)|\d+/m';
$str = '#foo1,bar2:#baz3 4';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;