use strict;
my $str = '#foo1,bar2:#baz3 4';
my $regex = qr/(#\w+)|\d+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";