const regex = /(#\w+)|\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(#\\w+)|\\d+', 'gm')
const str = `#foo1,bar2:#baz3 4`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);