#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+|\w+\.)+@\w+\.\w+$"
Local $sString = "toto@tata.fr" & @CRLF & _
"123 @tutu.fr" & @CRLF & _
"123_@tutu.fr" & @CRLF & _
"az3.ert@tete.fr" & @CRLF & _
"ucugc-ftg@ce.ft" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")