re = /^(\w+|\w+\.)+@\w+\.\w+$/m
str = 'toto@tata.fr
123 @tutu.fr
123_@tutu.fr
az3.ert@tete.fr
ucugc-ftg@ce.ft
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end