package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+|\w+\.)+@\w+\.\w+$`)
var str = `toto@tata.fr
123 @tutu.fr
123_@tutu.fr
az3.ert@tete.fr
ucugc-ftg@ce.ft
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}