$re = '/^(\w+|\w+\.)+@\w+\.\w+$/m';
$str = 'toto@tata.fr
123 @tutu.fr
123_@tutu.fr
az3.ert@tete.fr
ucugc-ftg@ce.ft
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);