# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<td[^>]*\bstyle="[^"]*;)([^"]*">In order to stop receiving)/$1font-size: 80%;$2/;t' <<< "<tr>
<td style=\"color:#555555;padding-top: 3px;padding-bottom: 20px;\">In order to stop receiving similar emails, simply remove the relevant <a href=\"https://domain.tld/dashboard/?module=saved-searches\" target=\"_blank\">saved search</a> from your account.</td>
</tr>"