re = /(<td[^>]*\bstyle="[^"]*;)([^"]*">In order to stop receiving)/
str = '<tr>
<td style="color:#555555;padding-top: 3px;padding-bottom: 20px;">In order to stop receiving similar emails, simply remove the relevant <a href="https://domain.tld/dashboard/?module=saved-searches" target="_blank">saved search</a> from your account.</td>
</tr>'
subst = '$1font-size: 80%;$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result