const regex = /(<td[^>]*\bstyle="[^"]*;)([^"]*">In order to stop receiving)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<td[^>]*\\bstyle="[^"]*;)([^"]*">In order to stop receiving)', '')
const str = `<tr>
<td style="color:#555555;padding-top: 3px;padding-bottom: 20px;">In order to stop receiving similar emails, simply remove the relevant <a href="https://domain.tld/dashboard/?module=saved-searches" target="_blank">saved search</a> from your account.</td>
</tr>`;
const subst = `$1font-size: 80%;$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);