// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<td[^>]*\bstyle="[^"]*;)([^"]*">In order to stop receiving)"#).unwrap();
let string = "<tr>
<td style=\"color:#555555;padding-top: 3px;padding-bottom: 20px;\">In order to stop receiving similar emails, simply remove the relevant <a href=\"https://domain.tld/dashboard/?module=saved-searches\" target=\"_blank\">saved search</a> from your account.</td>
</tr>";
let substitution = "$1font-size: 80%;$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}