package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[highlight](.*?)\[\/highlight]`)
var str = `[highlight][b]xxxxxx[/b][/highlight]
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}