use strict;
my $str = '[highlight][b]xxxxxx[/b][/highlight]
';
my $regex = qr/\[highlight](.*?)\[\/highlight]/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";