re = /\[highlight](.*?)\[\/highlight]/m
str = '[highlight][b]xxxxxx[/b][/highlight]
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result