package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)Ran Apply\b(?:.+?(\*\*Apply Error\*\*)|.*)`)
var str = `Ran Apply for dir: \`some random path/something/something\`
\`**Apply Error**\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}