$re = '`(?s)Ran Apply\b(?:.+?(\*\*Apply Error\*\*)|.*)`m';
$str = 'Ran Apply for dir: `some random path/something/something`
`**Apply Error**`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);