#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/([0-9a-zA-Z]+(\/)?)*([0-9a-zA-Z]+(\.[0-9a-zA-Z]+)*)$"
Local $sString = "/asasfjj" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/" & @CRLF & _
"/asdf" & @CRLF & _
"/asdf.php" & @CRLF & _
"/sdfsf/" & @CRLF & _
"/asdfsdf/asdf" & @CRLF & _
"/asdfsdf/sdf.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")