re = /^\/([0-9a-zA-Z]+(\/)?)*([0-9a-zA-Z]+(\.[0-9a-zA-Z]+)*)$/m
str = '/asasfjj
/
/asdf
/asdf.php
/sdfsf/
/asdfsdf/asdf
/asdfsdf/sdf.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end