$re = '/^\/([0-9a-zA-Z]+(\/)?)*([0-9a-zA-Z]+(\.[0-9a-zA-Z]+)*)$/m';
$str = '/asasfjj
/
/asdf
/asdf.php
/sdfsf/
/asdfsdf/asdf
/asdfsdf/sdf.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);