using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/([0-9a-zA-Z]+(\/)?)*([0-9a-zA-Z]+(\.[0-9a-zA-Z]+)*)$";
string input = @"/asasfjj
/
/asdf
/asdf.php
/sdfsf/
/asdfsdf/asdf
/asdfsdf/sdf.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}