using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(?:(-)(\d))+";
string substitution = @"El resultado es: \1\2\3";
string input = @"5-4-2
El primer grupo es el primer número
El segundo grupo es la operación (para simplificar, siempre resta)
El tercer grupo es el siguiente número
El problema es que con esta expresión: (?:(-)(\d))+
capturas ""-4"", pero como se puede repetir,
luego capturas ""-2"" y machacas los valores que tenías
en el segundo y tercer grupo de captura";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}