re = /(\d)(?:(-)(\d))+/m
str = '5-4-2
El primer grupo es el primer número
El segundo grupo es la operación (para simplificar, siempre resta)
El tercer grupo es el siguiente número
El problema es que con esta expresión: (?:(-)(\\d))+
capturas "-4", pero como se puede repetir,
luego capturas "-2" y machacas los valores que tenías
en el segundo y tercer grupo de captura'
subst = 'El resultado es: \\1\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result