import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d)(?:(-)(\\d))+";
final String string = "5-4-2\n\n"
+ "El primer grupo es el primer número\n"
+ "El segundo grupo es la operación (para simplificar, siempre resta)\n"
+ "El tercer grupo es el siguiente número\n\n"
+ "El problema es que con esta expresión: (?:(-)(\\d))+\n"
+ "capturas \"-4\", pero como se puede repetir, \n"
+ "luego capturas \"-2\" y machacas los valores que tenías \n"
+ "en el segundo y tercer grupo de captura";
final String subst = "El resultado es: \\1\\2\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}