// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d)(?:(-)(\d))+").unwrap();
let string = "5-4-2
El primer grupo es el primer número
El segundo grupo es la operación (para simplificar, siempre resta)
El tercer grupo es el siguiente número
El problema es que con esta expresión: (?:(-)(\\d))+
capturas \"-4\", pero como se puede repetir,
luego capturas \"-2\" y machacas los valores que tenías
en el segundo y tercer grupo de captura";
let substitution = "El resultado es: \\1\\2\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}